08 Sep 2021, 10:23

Certbot
XXX lists XXX

my certificate is expired and certbot

OMG

This gives me a message “your current client, does not support ACME v2 at all. You will need to migrate to a different one”, but there is nothing I can do to update my certbot.

So I did some googling around, and found nothing that helped me.

It is worth to note that this was in an old server with ubuntu 17.

Now there is one thing I can do: remove it and install it again!

step 1: removing

sudo apt remove certbot
...
certbot removed!

step 2: install it again

sudo apt install certbot
...
...
error!

Oh noes fuuuuuuuuuuuuuuuuuuu!!!!

ok, no panic. lets check the documentation.

sudo snap install --classic certbot

Well, I am not a fan of snap, usually try to keep as much as possible with flatpack, but let’s try

hey, it worked!

so I run

sudo systemctl stop nginx.service
sudo certbot renew
sudo systemctl start nginx.service

open the website and … bob is your uncle!

success